If Moon Cafe and Venus are not working, clear cache on Chrome. Here's how:

Hey guys, so some of us have encountered issues entering Moon Cafe and/or Venus Room, and may have been presented with an error message that says “Invalid meeting ID”. Here are the steps to resolve the issue for Google Chrome users—no guarantee it works for everyone though. Credits to D (who wants to stay anonymous) for the solution!

  1. In the Live Environment (https://2021.polyglotconference.com/), click on your browser’s options button represented by three dots in the top right corner of your window (just below the ‘Close’ button for Windows users)

  2. Go to ‘More tools’ > ‘Developer tools’ - alternatively just use the following shortcut: Ctrl+Shift+I

  3. Right-click on the ‘Reload’ button (note: do not left-click) and select ‘Empty Cache and Hard Reload’

That’s about it, hopefully these steps help anyone who’s facing a similar issue!


If anyone is having trouble now, try refreshing your screen or browser. That worked for me on Chrome for Mac

1 Like

What exactly is Moon Cafe?

People come in and out, and we chat about whatever. Basically a chill hangout room.


Thanks for that, but where is the “reload button”? This was working fine for me yesterday but now it keeps saying I am not authorized for the meeting though I am signed in. THanks.

Thank you. I’ll check it out

I’m getting an error that says, “This meeting is for authorized attendees only.” Clearing the cache did not fix this. I’ve tried three different web browsers, and even tried two separate devices, but I cannot get into Moon or Venus.

Hello Everyone!

Sorry for the tech issues with Zoom. I have spoken to their CS people for way more hours than I’d care to admit to here. Suffice to say I think I will be invited to their next big life events!

Seriously though, they have changed quite a lot of stuff in the settings. They seem to have added things following a lot of Zoom bombers last year and they have definitely taken a step down in tech support to help get around the issues.

I have not actually changed anything from last year and so I am unsure why the issues are occurring. That said I did spend a lot of time looking at some problems and tried to overcome them.

The current situation with The Moon Cafe and Venus Room is that they need you to be logged into a Zoom account (and possibly Google from what I am seeing). When you are logged into them, then the system at Zoom sees you are authenticated and allows you in.

Other steps to take:

  1. Log out of The Live Environment
  2. Clear your cache (hard clear best)
  3. Restart your machine.
  4. Log into Zoom & Google
  5. Log into The Live Environment

My hope is that having done all that you should be fine to get into any room.

If not, please don’t hestiate to let me know and I will see what else I can do. My biggest issue at the moment is that some people get in, some don’t and everyone has a different issue. So it’s tough to ping down what is actually happening.

In any case, I wish you good luck and I look forward to seeing you sooon!


Hi, I had the same problems like Amanda Gillis. I think it may be an issue of the device, bc it never works on my iPad, asks for a passcode or won’t let me in. I will try now with try laptop, hoping it works! Is it possible to get a passcode? Thank you!

Just tried from my laptop, and that also doesn’t work for Moon Cafe or Venus Room:-( I think we may need a passcode, because some of us don’t have zoom accounts we can log into, so we need to login per meeting. I tried Richard’s steps but the fundamental problem is that Zoom isn’t allowing us in. Any other solutions? Bc Moon Cafe and Venus are such an integral part of the conference and after. Really sad not to be able to join in those!

PS to be more specific, I couldn’t do the hard clear because I couldn’t find that button under the developer’s tools! But I tried everything else, and Moon and Venus worked all last year for me without a problem.

Hi Sonja! @MsPolyglot my error message on my phone was that Zoom asked me to log in using my account, I have a free one and I successfully entered using my ID just once for all the rooms (I don’t need to login per meeting). Hope this works for you if you have a free account.

If the message asks for a “secret code”, the code is there on the meeting URL of each rooms and you just have to copy & paste it.

In the meantime, please do check empty Earth Exchange rooms because some people who had problems entering Moon & Venus hang out over there (including me!) :slight_smile:

I was eventually able to get into Venus and Moon following the information that Richard provided. I think that logging into Zoom was what resolved it for me. I do not have a paid account with Zoom; the free account was sufficient. I don’t know why logging in was necessary today, since I had not had to do so for the first few days of the conference, but Zoom can be weird sometimes.

In addition to the Venus and Moon channels, the recently-added Earth Exchange 5 room has the same issue for me. Fortunately the other four are still working for me, since I don’t really want to (have to) create a Zoom account.